Thumbnail slike so izginile v Wordpresu




Nekega dne preprosto ni bilo več možno videti prikazne slike (feature image) pri posameznem prispevku na mojem blogu, na srečo so bile slike vidne znotraj prispevka. Le kaj je šlo narobe?

Govorimo seveda o blogu, ki je na platformi WordPress. Poleg tega slik ni bilo možno videti niti v Galeriji, da je bila zmeda še večja, pa so nekatere slike bile vidne povsod.  Predvsem je bil problem pri slikah s formatom PNG, manj pri jpg.
Možnih je več rešitev. Včasih bo dovolj ena, včasih bo potrebno uporabiti vse.

Prva rešitev

Nekateri pogosto uporabijo sliko v prispevku in nato isto tudi kot Feature image, kar WordPress zmede, še posebej, če je aktivna predloga, ki avtomatično doda feature image v prispevek.
Torej priporočljivo je, da sliko, ki jo uporabimo kot feature image, ne dodamo še dodatno v prispevek.

 

Druga rešitev

Namestila sem nov vtičnik Thumbnail Cleaner. Cleaner odstrani in nato ponovno kreira thumbnails.

Ta rešitev mi je pomagala le delno, a ga priporočam za občasno aktiviranje.

 

Tretja rešitev

Pri slikah, ki so vidne v prispevku, ne pa tudi v galeriji je možno, da so se pokvarile njihove povezave v knjižnici slik. V tem primeru se namesti vtičnik WP Original Media Path

Tretja rešitev je bila prava odrešitev pri meni in od takrat naprej nimam več problemov glede prikazovanja slik v prispevkih ali v knjižnici slik.

 

Saša

Works as system engineer in Slovenian Enterprise in Microsoft environment focusing on security, deployments, SharePoint, SCCM and CheckPoint firewall. Author of successful blog about IT security, Microsoft tips & tricks, social media, internet trends.

Leave a Reply